Work has started to service you from https://app.claritalk.com

COMPLETED

De werken zijn beëindigd. We danken u voor uw geduld. We vertrouwen erop dat deze update extra klaarheid brengt in uw gesprekken.

Posted 1 month ago.

IN PROGRESS

Scheduled maintenance is currently in progress.

Posted 1 month ago.

SCHEDULED

The systems will be upgrading for several hours - service is interrupted. Afterwards, all checks will be performed and we resume normal service at Monday morning 6 AM CET.

Posted 1 month ago.